npm install 명령을 수행할 때 아래와 같은 404 에러가 나는 경우가 있다. 

npm ERR! code E404 npm ERR! 404 Not Found

혹은 아래와 같은 경고 메시지가 뜨기도 한다

This version of npm is compatible with lockfileVersion@1, 
but package-lock.json was generated for lockfileVersion@0. 
I'll try to do my best with it!

 

이 경우에는 package-lock.json 파일을 삭제한 후에 다시 인스톨을 시도해 보면 해결된다. rm 명령어로 지워도 되고, 윈도우즈 환경이라면 파일 검색기에서 package-lock.json 파일을 직접 찾아서 삭제해도 된다. 

package-lock.json 파일은 의존성 트리에 대한 정보를 가지고 있다.

댓글을 달아주세요!
이름 암호 홈페이지